Subject: pgAdmin III commit: A manual merge of few last commits from libssh2 res

From: Ashesh Vashi <[email-masked]>
Date: Wed, 09 Dec 2015 07:23:20 +0000

A manual merge of few last commits from libssh2 resulted into an critical issue.

Branch
------
master

Details
-------
http://git.postgresql.org/gitweb?p=pgadmin3.git;a=commitdiff;h=5b2f89173e0da9c27afe4aa686e43dd46c9666ae
Author: Dmitriy Olshevskiy <[email-masked]>

Modified Files
--------------
pgadmin/libssh2/hostkey.c |    2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

-- 
Sent via pgadmin-hackers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-hackers

---

From: Timon <[email-masked]>
Date: Wed, 9 Dec 2015 14:50:19 +0300

forget ; at end of line

diff --git a/pgadmin/libssh2/hostkey.c b/pgadmin/libssh2/hostkey.c
index 3b72782..09955d7 100644
--- a/pgadmin/libssh2/hostkey.c
+++ b/pgadmin/libssh2/hostkey.c
@@ -94,7 +94,7 @@ hostkey_method_ssh_rsa_init(LIBSSH2_SESSION * session,
     n = s;

     ret = _libssh2_rsa_new(&rsactx, e, e_len, n, n_len, NULL, 0,
-                     NULL, 0, NULL, 0, NULL, 0, NULL, 0, NULL, 0)
+                     NULL, 0, NULL, 0, NULL, 0, NULL, 0, NULL, 0);
     if (ret) {
         return -1;
     }

-- 
All bugs reserved

---

From: Ashesh Vashi <[email-masked]>
Date: Wed, 9 Dec 2015 18:23:56 +0530

Thanks for pointing that out quickly.
I've made the changes. (I certainly need the break).

--

Thanks & Regards,

Ashesh Vashi
EnterpriseDB INDIA: Enterprise PostgreSQL Company
<http://www.enterprisedb.com>

*http://www.linkedin.com/in/asheshvashi*
<http://www.linkedin.com/in/asheshvashi>