Subject: pgAdmin 4 Running Very Slow on macOS

From: Vibha Pateshwari <[email-masked]>
Date: Sat, 16 Aug 2025 15:23:16 +0530

Hello pgAdmin Support Team,

I am experiencing a persistent issue with pgAdmin 4 on my MacBook (macOS
[your version, e.g., 10.15.7 Catalina]). The application feels very slow
and unresponsive, even after I tried the following steps:

   -

   Cleared unnecessary files and freed disk space
   -

   Deleted old pgAdmin logs and cache
   -

   Disabled auto–server discovery and auto–connect options
   -

   Restarted PostgreSQL service

Despite these attempts, pgAdmin still takes a long time to load and respond
to queries.

Could you please help me troubleshoot this issue?
Here are some details of my setup:

   -

   pgAdmin version: [e.g., 8.x]
   -

   PostgreSQL version: [e.g., 17]
   -

   macOS version: [e.g., 10.15.7 Catalina]
   -

   Hardware: [e.g., MacBook Air M2, 8GB RAM]

I would really appreciate any guidance on resolving this performance issue.

Thank you for your support.

Best regards,
Vibha Pateshwari

---

From: Darren Duncan <[email-masked]>
Date: Mon, 18 Aug 2025 01:02:05 -0700

Vibha, what do you mean by "Macbook Air M2"?

Also, what do you mean by "e.g."?

Normally the latter means "for example", but that's not the same as your saying 
you actually have something.

Also the term "M2" usually refers to Apple Silicon M2 processor which is fairly 
current, while MacOS 10.15.7 Catalina is about 7 years old and doesn't run on 
any Apple Silicon released to the public.

Have you tried looking at your Activity Monitor program to see what uses a lot 
of resources and hence could lead to slowness?

Darren Duncan

On 2025-08-16 2:53 a.m., Vibha Pateshwari wrote:
> I am experiencing a persistent issue with pgAdmin 4 on my MacBook (macOS [your 
> version, e.g., 10.15.7 Catalina]). The application feels very slow and 
> unresponsive, even after I tried the following steps:
> 
>   *
> 
>   *
>   *
>   *
> Despite these attempts, pgAdmin still takes a long time to load and respond to 
> queries.
> 
>   *
>   *
>   *
>   *