Subject: Help with remediation for vulnerabilities for pgadmin4 version 9.x in RH8

From: Kristen Delack <[email-masked]>
Date: Mon, 1 Jun 2026 16:00:31 -0400

Hello pgadmin list,

I am the Operations & Maintenance software development team lead on the
National Weather Service's (NWS) Advanced Weather Interactive Processing
System (AWIPS) program. We use pgadmin4 on RHEL8. We just recently upgraded
to version 9.12 before a new vulnerability
<https://www.cve.org/CVERecord?id=CVE-2026-7820> in versions up through
9.14 was announced. We see that version 9.15 mitigates this vulnerability,
but according to your page <https://www.pgadmin.org/download/pgadmin-4-rpm/>,
9.14 is the last supported release for RH8. Does this mean that no further
versions of 9.x for RH8 will be released when vulnerabilities are found?

Thanks in advance for your feedback!

Kristen Delack
AWIPS ASM Lead
Raytheon Technologies
Ph. 667.257.7616

---

From: Darren Duncan <[email-masked]>
Date: Wed, 3 Jun 2026 03:48:01 -0700

On 2026-06-01 1:00 p.m., Kristen Delack wrote:
> I am the Operations & Maintenance software development team lead on the National 
> Weather Service's (NWS) Advanced Weather Interactive Processing System (AWIPS) 
> program. We use pgadmin4 on RHEL8. We just recently upgraded to version 9.12 
> before a new vulnerability <https://www.cve.org/CVERecord?id=CVE-2026-7820> in 
> versions up through 9.14 was announced. We see that version 9.15 mitigates this 
> vulnerability, but according to your page <https://www.pgadmin.org/download/ 
> pgadmin-4-rpm/>, 9.14 is the last supported release for RH8. Does this mean that 
> no further versions of 9.x for RH8 will be released when vulnerabilities are found?
That is usually what this means, yes.

But this should not be too big of a challenge for you to overcome.

Since PgAdmin4 is a database client program and not a server, it should be 
fairly low risk for you to just use a machine with a newer operating system than 
RH8 and run the latest most secure PgAdmin4 on it instead.

Being a client, nothing else has to talk to or be compatible with the new machine.

So you can upgrade to the latest PgAdmin4 without having to update anything else 
really at the same time.

The new machine can be just for running PgAdmin4 initially.

Darren Duncan

---

From: Dave Page <[email-masked]>
Date: Wed, 3 Jun 2026 13:19:56 +0100

Hi

On Wed, 3 Jun 2026 at 09:19, Kristen Delack <[email-masked]> wrote:

> but according to your page
> <https://www.pgadmin.org/download/pgadmin-4-rpm/>, 9.14 is the last
> supported release for RH8. Does this mean that no further versions of 9.x
> for RH8 will be released when vulnerabilities are found?
>

Correct, there will be no more releases for RH8 as it's beyond it's
standard support lifetime, and we have limited resources to maintain builds.

-- 
Dave Page
pgAdmin: https://www.pgadmin.org
PostgreSQL: https://www.postgresql.org
pgEdge: https://www.pgedge.com

---

From: Kristen Delack <[email-masked]>
Date: Wed, 3 Jun 2026 17:24:08 -0400

Hi Dave,

Understood. Thank you for your response.

Kristen Delack
AWIPS ASM Lead
Raytheon Technologies
Ph. 667.257.7616