Subject: PGAdmin Connectivity Issues

From: Ami Chovatiya <[email-masked]>
Date: Tue, 25 Mar 2025 11:24:40 +0000

Hello,

I hope this email finds you well!

We have a few engineers using pgadmin for postgres access, and they are running into the error below.

Connection failed: connection to server at "100.64.1.5", port 5432 failed: FATAL: KERB_VALIDATION_INFO::UserFlags has USER_FLAGS_EXTRA_SIDS set, but there are no ExtraSids.

Please note that this error is only getting thrown for two users at the moment; everyone else can connect. From a system's perspective, all permissions align for the users that have access.

Would you be able to share what causes this error to get generated and what the solution is?

Thanks,

Ami Chovatiya

CoStar Group

[email-masked]<mailto:[email-masked]>

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 26 Mar 2025 15:30:22 +0530

Hi,

On Wed, Mar 26, 2025 at 3:05 PM Ami Chovatiya <[email-masked]> wrote:

> *Connection failed: connection to server at "100.64.1.5", port 5432
> failed: FATAL: KERB_VALIDATION_INFO::UserFlags has USER_FLAGS_EXTRA_SIDS
> set, but there are no ExtraSids.*
>
> Are you using Kerberos for Postgres connection?

> Please note that this error is only getting thrown for two users at the
> moment; everyone else can connect. From a system's perspective, all
> permissions align for the users that have access.
>
> *Ami Chovatiya*
> [email-masked] <[email-masked]>
>

---

From: Ami Chovatiya <[email-masked]>
Date: Wed, 26 Mar 2025 11:36:58 +0000

Hello Khushboo,

Yes, we are using Kerberos for postgres connections.

Thanks,

Ami Chovatiya

CoStar Group

________________________________
From: Khushboo Vashi <[email-masked]>
Sent: Wednesday, March 26, 2025 6:00 AM
To: Ami Chovatiya <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: PGAdmin Connectivity Issues

EXTERNAL EMAIL
Hi,

On Wed, Mar 26, 2025 at 3:05 PM Ami Chovatiya <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Thanks,

Ami Chovatiya

CoStar Group

---

From: Khushboo Vashi <[email-masked]>
Date: Wed, 26 Mar 2025 17:36:09 +0530

Hello,

It looks like it has something to do with your Kerberos user login issue;
it's not a pgAdmin issue. The error suggests an ExtraSids misconfiguration,
which is part of the Kerberos validation info structure.
Refer:
https://learn.microsoft.com/en-us/openspecs/windows_protocols/ms-pac/69e86ccc-85e3-41b9-b514-7d969cd0ed73

Thanks,
Khushboo

On Wed, Mar 26, 2025 at 5:07 PM Ami Chovatiya <[email-masked]> wrote:

> ------------------------------
> *From:* Khushboo Vashi <[email-masked]>
> *Sent:* Wednesday, March 26, 2025 6:00 AM
> *To:* Ami Chovatiya <[email-masked]>
> *Cc:* [email-masked] <
> [email-masked]>
> *Subject:* Re: PGAdmin Connectivity Issues
>
> EXTERNAL EMAIL
> Hi,
>