Subject: Bug

From: Faran Ali <[email-masked]>
Date: Tue, 25 Jun 2019 14:47:07 +0500

Hi,
*pgAdmin: *v4.8
*OS: *Tried on Ubuntu 19.04/18.10/18.04
*Server Mode: *True
*Python: *Tried Python 3.5/3.6/3.7/3.8

I've Installed pgAdmin from APT repository and while others can get it to
work simply I get an error in the screen attached below whenever I try to
take a backup or restore from pgAdmin

Please let me know if you need anything else.

Regards,
Faran.

---

From: Fahar Abbas <[email-masked]>
Date: Tue, 25 Jun 2019 14:59:19 +0500

Adding  [email-masked] email and Removing pgsql-bugs
email.

Hi Faran!

Can you please share the pgadmin4.log file as well?

Kind regards,

-- 
Fahar Abbas
QMG
EnterpriseDB Corporation
Phone Office: +92-51-835-8874
Phone Direct: +92-51-8466803
Mobile: +92-333-5409707
Skype ID: *live:fahar.abbas*
Website: www.enterprisedb.com

---

From: Christoph Berg <[email-masked]>
Date: Tue, 25 Jun 2019 12:05:25 +0200

Re: Fahar Abbas 2019-06-25 <[email-masked]>
> > take a backup or restore from pgAdmin

That's https://redmine.postgresql.org/issues/4088

The packages use python3, and I haven't yet told the pgadmin4 backup
machinery to do that as well. (At least that's what I think the
problem is, haven't investigated yet.)

Christoph

---

From: Faran Ali <[email-masked]>
Date: Tue, 25 Jun 2019 15:12:45 +0500

---------- Forwarded message ---------
From: Faran Ali <[email-masked]>
Date: Tue, Jun 25, 2019 at 3:08 PM
Subject: Re: Bug
To: Christoph Berg <[email-masked]>

Hi,
Please find the log attached below

Regards,
Faran.

On Tue, Jun 25, 2019 at 3:05 PM Christoph Berg <[email-masked]> wrote:

> Re: Fahar Abbas 2019-06-25 <
> [email-masked]>

---

From: Michael Paquier <[email-masked]>
Date: Wed, 26 Jun 2019 11:01:25 +0900

> take a backup or restore from pgAdmin

You may want to contact the pgadmin crew here:
https://www.pgadmin.org/support/list/
--
Michael

---

From: Christoph Berg <[email-masked]>
Date: Wed, 26 Jun 2019 15:32:10 +0200

Re: To Fahar Abbas 2019-06-25 <[email-masked]>
> problem is, haven't investigated yet.)

Could you try the 4.8-3 packages I uploaded some hours ago?

Christoph