Subject: Version 8.13 now encapsulates any copy and paste value in double quotes - how to remove that?

From: Calle Hedberg <[email-masked]>
Date: Tue, 3 Dec 2024 17:38:29 +0100

Hi,
Version 8.13 has introduced encapsulation in double quotes for any value
copied from one row/column to another row/column.
That will not work for me, so how can I turn that new "feature" OFF?

Best regards
Calle Hedberg

---

From: PABLO ANDRES IBARRA DUPRAT <[email-masked]>
Date: Tue, 3 Dec 2024 16:57:22 +0000

Hi ..

                                               Didi you try this?:
                                               Open File->Preferences from the menu, then navigate to "Query Tool"->"Results grid", and change the "Result copy quote character" as needed

                                               Greetings

De: Calle Hedberg <[email-masked]>
Enviado el: martes, 3 de diciembre de 2024 13:38
Para: pgAdmin Support <[email-masked]>
Asunto: Version 8.13 now encapsulates any copy and paste value in double quotes - how to remove that?

Hi,
Version 8.13 has introduced encapsulation in double quotes for any value copied from one row/column to another row/column.
That will not work for me, so how can I turn that new "feature" OFF?

Best regards
Calle Hedberg
ADVERTENCIA: E-Mail externo, favor verifique remitente, no descargue archivos adjuntos de remitentes desconocidos, no haga Clic en enlaces. Ante sospechas reporte a Seguridad de Información Itau [email-masked]<mailto:[email-masked]>
Para asegurar la adecuada lectura en todo tipo de correos electronicos, se han omitido intencionalmente los signos y acentos diacriticos del idioma castellano. La informacion contenida en este mensaje y cualquier archivo adjunto es confidencial y no puede ser usada por mas personas que sus destinatarios. El uso no autorizado de esta informacion puede ser sancionado de conformidad con el Codigo Penal chileno. Si ha recibido este correo por error, por favor notifique al remitente respondiendo este mismo mensaje y elimine el mensaje y todos los archivos adjuntos. Internet no puede garantizar la integridad de este mensaje, por lo que el Banco no se hace responsable si el contenido del mismo ha sido alterado.

---

From: Aditya Toshniwal <[email-masked]>
Date: Wed, 4 Dec 2024 09:56:05 +0530

Hi Calle,

The issue is reported here -
https://github.com/pgadmin-org/pgadmin4/issues/8213

-- 
Thanks,
Aditya Toshniwal
pgAdmin Hacker | Sr. Staff SDE II | *enterprisedb.com*
<https://www.enterprisedb.com/>
"Don't Complain about Heat, Plant a TREE"

---

From: Calle Hedberg <[email-masked]>
Date: Wed, 4 Dec 2024 06:42:32 +0100

Pablo,

Changing that setting has no impact on this issue - as confirmed by Aditya,
it is actually a bug.

But when reading the bug report, I see there IS a workaround, of sorts: You
can use CTRL-X (cut) instead of CTRL-C (copy), the paste it back to the
original position before pasting it into the new position. Messy, but maybe
a little bit quicker than using CTRL-C and then delete the double quotes
etc.

I any case, I hope this regression bug will be fixed asap.

Aditya, thank you very much for clarifying that the issue has been reported
and accepted as a bug.

Best regards
Calle