Subject: [pgjdbc/pgjdbc] PR #1637: Only allow binary transfer for those Oids that the pgjdbc currently s…

From: "mahmoudbahaa (@mahmoudbahaa)" <[email-masked]>
Date: Thu, 05 Dec 2019 15:09:37 +0000

…upports

### All Submissions:

* [x] Have you followed the guidelines in our [Contributing](https://github.com/pgjdbc/pgjdbc/blob/master/CONTRIBUTING.md) document?
* [x] Have you checked to ensure there aren't other open [Pull Requests](../../pulls) for the same update/change?

<!-- You can erase any parts of this template not applicable to your Pull Request. -->

### New Feature Submissions:

1. [x] Does your submission pass tests?
2. [x] Does mvn checkstyle:check pass ?
3. [ ] Have you added your new test classes to an existing test suite in alphabetical order?

### Changes to Existing Features:

* [ ] Does this break existing behaviour? If so please explain.
* [x] Have you added an explanation of what your changes do and why you'd like us to include them?
* [ ] Have you written new tests for your core changes, as applicable?
* [x] Have you successfully run tests with your changes locally?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 05 Dec 2019 15:25:00 +0000

thanks!

---

From: "codecov-io (@codecov-io)" <[email-masked]>
Date: Thu, 05 Dec 2019 17:52:41 +0000

# [Codecov](https://codecov.io/gh/pgjdbc/pgjdbc/pull/1637?src=pr&el=h1) Report
> Merging [#1637](https://codecov.io/gh/pgjdbc/pgjdbc/pull/1637?src=pr&el=desc) into [master](https://codecov.io/gh/pgjdbc/pgjdbc/commit/08bd46bfccc9c9481650e4ee09c943ec78d77895?src=pr&el=desc) will **increase** coverage by `<.01%`.
> The diff coverage is `100%`.

```diff
@@             Coverage Diff              @@
##             master    #1637      +/-   ##
============================================
+ Coverage     69.06%   69.06%   +<.01%     
+ Complexity     4084     4083       -1     
============================================
  Files           181      181              
  Lines         16886    16890       +4     
  Branches       2771     2771              
============================================
+ Hits          11662    11665       +3     
  Misses         3946     3946              
- Partials       1278     1279       +1
```

---

From: "mahmoudbahaa (@mahmoudbahaa)" <[email-masked]>
Date: Fri, 06 Dec 2019 08:56:28 +0000

@davecramer all checks are now green

---

From: "codecov-commenter (@codecov-commenter)" <[email-masked]>
Date: Wed, 01 Apr 2026 20:36:56 +0000

:warning: Please install the !['codecov app svg image'](https://github.com/codecov/engineering-team/assets/152432831/e90313f4-9d3a-4b63-8b54-cfe14e7ec20d) to ensure uploads and comments are reliably processed by Codecov.

## [Codecov](https://app.codecov.io/gh/pgjdbc/pgjdbc/pull/1637?dropdown=coverage&src=pr&el=h1&utm_medium=referral&utm_source=github&utm_content=comment&utm_campaign=pr+comments&utm_term=pgjdbc) Report
:white_check_mark: All modified and coverable lines are covered by tests.
:white_check_mark: Project coverage is 68.81%. Comparing base ([`c85b149`](https://app.codecov.io/gh/pgjdbc/pgjdbc/commit/c85b149d68c30ede0559d4bff6bc616ec03b2517?dropdown=coverage&el=desc&utm_medium=referral&utm_source=github&utm_content=comment&utm_campaign=pr+comments&utm_term=pgjdbc)) to head ([`7ec5052`](https://app.codecov.io/gh/pgjdbc/pgjdbc/commit/7ec50520470c7dd25b4a16d996e0533e56dc3f70?dropdown=coverage&el=desc&utm_medium=referral&utm_source=github&utm_content=comment&utm_campaign=pr+comments&utm_term=pgjdbc)).
:warning: Report is 1506 commits behind head on master.
:exclamation: Your organization needs to install the [Codecov GitHub app](https://github.com/apps/codecov/installations/select_target) to enable full functionality.

<details><summary>Additional details and impacted files</summary>

```diff
@@             Coverage Diff              @@
##             master    #1637      +/-   ##
============================================
- Coverage     69.10%   68.81%   -0.29%     
+ Complexity     4112     4088      -24     
============================================
  Files           181      181              
  Lines         16954    16956       +2     
  Branches       2789     2789              
============================================
- Hits          11716    11669      -47     
- Misses         3954     4010      +56     
+ Partials       1284     1277       -7     
```
</details>
<details><summary> :rocket: New features to boost your workflow: </summary>

- :snowflake: [Test Analytics](https://docs.codecov.com/docs/test-analytics): Detect flaky tests, report on failures, and find test suite problems.
</details>