Subject: [pgjdbc/pgjdbc] PR #2097: report precise version of postgres on appveyor

From: "adunstan (@adunstan)" <[email-masked]>
Date: Sat, 13 Mar 2021 14:33:41 +0000

one line change to make the full PostgreSQL version be reported on appveyor

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Sat, 13 Mar 2021 15:03:31 +0000

This is a good idea. We should have it for the Linux platforms as well. I'm going to tweak this PR and I'll merge in one that does both in a bit.

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Sat, 13 Mar 2021 15:27:15 +0000

I'm reworking this a bit to do it via a separate JDBC test that executes `SELECT version()` on the default test JDBC connection. That way it'll be the same thing that runs on all platforms and should match the actual server being tested regardless of platform (ex: connecting over SSL vs non-SSL).

I'm thinking of printing the results of `SHOW ALL` as well. Any security implications on doing so? I wouldn't expect anything sensitive to be in there so I think it's fine.

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Wed, 18 Mar 2026 14:21:34 +0000

We no longer use Appveyor: https://github.com/pgjdbc/pgjdbc/pull/3966