Subject: [pgjdbc/pgjdbc] issue #2551: Add tests with Java 18, 19, 20

From: "vlsi (@vlsi)" <[email-masked]>
Date: Fri, 17 Jun 2022 14:45:16 +0000

See https://github.com/oracle-actions/setup-java
See https://github.com/junit-team/junit5/pull/2944

I think CI matrix should be something like "build with Java X", "test with Java Y".

It might help us if we create version-specific source sets (folders) and produce multi-release jar as the result.
Then we could require something like "pgjdbc must be built with Java 11+ or 17+" while still targeting Java 8 or whatever.

However, I believe the starting point should be adding Gradle toolchains https://docs.gradle.org/current/userguide/toolchains.html for test purposes (e.g. a separate build time parameter that would specify JVM for tests).

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sat, 14 Jun 2025 09:02:18 +0000

Implemented in #3026