Subject: [pgjdbc/pgjdbc] PR #3154: issue #3153: return XAER_NOTA on rollback

From: "jmfinelli (@jmfinelli)" <[email-masked]>
Date: Wed, 06 Mar 2024 13:22:42 +0000

### Changes to Existing Features:

* Does this break existing behaviour? If so please explain.
  * It does not break existing behaviour
* Have you added an explanation of what your changes do and why you'd like us to include them?
  * Yep, I wrote an explanation in the related issue (#3153)
* Have you written new tests for your core changes, as applicable?
  * I modified a test of  `XADataSourceTest`
* Have you successfully run tests with your changes locally?
  * Yes, I have tested my changes using `./gradlew test`

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Wed, 27 May 2026 09:28:24 +0000

Closing in favour of https://github.com/pgjdbc/pgjdbc/pull/4114