Subject: Re: [pgjdbc/pgjdbc] PR #3232: add windows-latest as it supports docker

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sat, 27 Apr 2024 13:43:57 +0000

(on .github/workflows/main.yml:101)

should we extract `shell` parameter to the matrix, so we use the same step without adding extra `if`?

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sat, 27 Apr 2024 13:44:23 +0000

Will it spawn Windows-based PostgreSQL or Linux-based one?

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Sat, 27 Apr 2024 15:25:08 +0000

Ah that's interesting. So this would be testing some JDK running on Windows vs a Linux Postgres running in Docker?

If we're going to test against Windows (i.e. duplicate what's in AppVeyor), could have a separate branch for the server itself running on Windows. The GitHub Runner installed software list for "windows-2022" says that it already has PostgreSQL 14.x installed: https://github.com/actions/runner-images/blob/main/images/windows/Windows2022-Readme.md#databases

I think we'd be kind of tied to whatever they include in the runner image, but that's not any worse than what we have in AppVeyor. With the advantage that it'd work for forks too.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sat, 27 Apr 2024 18:05:46 +0000

> Will it spawn Windows-based PostgreSQL or Linux-based one?

Well the reason I did this was because there are no windows postgresql docker images, hence running on ubuntu

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sat, 27 Apr 2024 18:06:53 +0000

> I think we'd be kind of tied to whatever they include in the runner image, but that's not any worse than what we have in AppVeyor. With the advantage that it'd work for forks too.

Yeah, well ideally we want to be able to test windows with different PostgreSQL versions. If we just want v14 then we can use whatever is there

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Wed, 18 Mar 2026 14:28:53 +0000

We use Windows-based PostgreSQL server: https://github.com/pgjdbc/pgjdbc/pull/3966
Could we probably close the PR?