Subject: [pgjdbc/pgjdbc] issue #3474: Jsonb dataType where xx ? 'gg' Syntax error use jsonb_exists index Invalid

From: "a75187 (@a75187)" <[email-masked]>
Date: Sat, 28 Dec 2024 00:56:10 +0000

**Java Version8**

**PostgreSQL Version10.12**

        <dependency>
            <groupId>org.postgresql</groupId>
            <artifactId>postgresql</artifactId>
            <version>42.6.0</version>
        </dependency>

  class :org.postgresql.core.v3.SimpleParameterList#checkAllParametersSet   
  throw an exception INVALID_PARAMETER_VALUE  but  Jsonb dataType , where  xx ? 'gg'   actual syntax correct

---

From: "a75187 (@a75187)" <[email-masked]>
Date: Sat, 28 Dec 2024 00:57:02 +0000

Am I the only one who encountered this?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sat, 28 Dec 2024 02:23:27 +0000

Be nice to see the code that caused this

---

From: "a75187 (@a75187)" <[email-masked]>
Date: Mon, 30 Dec 2024 12:13:59 +0000

> Be nice to see the code that caused this

why？

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 30 Dec 2024 12:15:19 +0000

So I can reproduce it and fix it

---

From: "a75187 (@a75187)" <[email-masked]>
Date: Fri, 03 Jan 2025 03:31:56 +0000

This seems to be a very common way of writing. I'm curious why no one has given feedback before, and why the JSON type is still less commonly used

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 03 Jan 2025 10:22:55 +0000

Do you want me to look at this ? If not please close the issue