Subject: [pgjdbc/pgjdbc] issue #3507: problem using 42.7.5 with jOOQ: llegalArgumentException: Field "key_seq" is not contained in row type

From: "FrankHossfeld (@FrankHossfeld)" <[email-masked]>
Date: Mon, 03 Feb 2025 07:03:53 +0000

A project using jOOQ and postgres with the latest postgres driver 42.7.5 fails to build. The following error message occurs:

```
java.lang.RuntimeException: java.lang.RuntimeException: java.lang.IllegalArgumentException: Field "key_seq" is not contained in row type (
  "PKTABLE_CAT",
  "pg_namespace"."PKTABLE_SCHEM",
  "pg_class"."PKTABLE_NAME",
  "pg_attribute"."PKCOLUMN_NAME",
  "FKTABLE_CAT",
  "pg_namespace"."FKTABLE_SCHEM",
  "pg_class"."FKTABLE_NAME",
  "pg_attribute"."FKCOLUMN_NAME",
  "KEY_SEQ",
  "UPDATE_RULE",
  "DELETE_RULE",
  "pg_constraint"."FK_NAME",
  "pg_class"."PK_NAME",
  "DEFERRABILITY"
)
```

The exception is thrown by jOOQ. Running the project with 42.7.4 works without problems. 

Is this problem related to jOOQ or to the driver?

---

From: "FrankHossfeld (@FrankHossfeld)" <[email-masked]>
Date: Mon, 03 Feb 2025 07:05:10 +0000

Looks like it is an issue related to jOOQ: https://github.com/jOOQ/jOOQ/issues/17930