Subject: [pgjdbc/pgjdbc] PR #3512: feat: enhanced DatabaseMetadata added index comment as REMARKS

From: "raminorujov (@raminorujov)" <[email-masked]>
Date: Thu, 06 Feb 2025 09:42:18 +0000

### All Submissions:
Implemented the feature suggestion in https://github.com/pgjdbc/pgjdbc/issues/3467
Enhanced DatabaseMetadata, added index comment as REMARKS property 

* [x] Have you followed the guidelines in our [Contributing](https://github.com/pgjdbc/pgjdbc/blob/master/CONTRIBUTING.md) document?
* [x] Have you checked to ensure there aren't other open [Pull Requests](../../pulls) for the same update/change?

<!-- You can erase any parts of this template not applicable to your Pull Request. -->

### New Feature Submissions:

1. [ ] Does your submission pass tests?
2. [x] Does `./gradlew styleCheck` pass ?
3. [x] Have you added your new test classes to an existing test suite in alphabetical order?

### Changes to Existing Features:

* [ ] Does this break existing behaviour? If so please explain.
* [ ] Have you added an explanation of what your changes do and why you'd like us to include them?
* [ ] Have you written new tests for your core changes, as applicable?
* [ ] Have you successfully run tests with your changes locally?

---

From: "raminorujov (@raminorujov)" <[email-masked]>
Date: Thu, 06 Feb 2025 09:46:03 +0000

Build fails on Windows with error `Could not find a part of the path 'C:\Program Files\PostgreSQL\9.6\data\postgresql.conf'`, which is not related to my change.