Subject: [pgjdbc/pgjdbc] PR #3513: feat: enhanced DatabaseMetadata.getIndexInfo() method, added index comment as REMARKS property

From: "raminorujov (@raminorujov)" <[email-masked]>
Date: Thu, 06 Feb 2025 11:08:16 +0000

Implemented the feature suggestion in [#3467](https://github.com/pgjdbc/pgjdbc/issues/3467)
Enhanced DatabaseMetadata, added index comment as REMARKS property

### All Submissions:

* [x] Have you followed the guidelines in our [Contributing](https://github.com/pgjdbc/pgjdbc/blob/master/CONTRIBUTING.md) document?
* [x] Have you checked to ensure there aren't other open [Pull Requests](../../pulls) for the same update/change?

<!-- You can erase any parts of this template not applicable to your Pull Request. -->

### New Feature Submissions:

1. [ ] Does your submission pass tests?
2. [x] Does `./gradlew styleCheck` pass ?
3. [x] Have you added your new test classes to an existing test suite in alphabetical order?

### Changes to Existing Features:

* [ ] Does this break existing behaviour? If so please explain.
* [ ] Have you added an explanation of what your changes do and why you'd like us to include them?
* [ ] Have you written new tests for your core changes, as applicable?
* [ ] Have you successfully run tests with your changes locally?

---

From: "raminorujov (@raminorujov)" <[email-masked]>
Date: Thu, 06 Feb 2025 11:11:33 +0000

Build fails on Windows with error `Could not find a part of the path 'C:\Program Files\PostgreSQL\9.6\data\postgresql.conf'`, which is not related to my change.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 06 Feb 2025 11:32:44 +0000

FYI
 DatabaseMetaData::getIndexInfo() and this method (and some others) has not included the REMARKS column since JDBC 1.0.2

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 06 Feb 2025 12:43:24 +0000

The rest of the methods like `getTables`, `getColumns` include `REMARKS`, so I think the miss of `REMARKS` in `getIndexInfo` is unintentional.

At the same time, adding vendor's columns is allowed:

> Additional columns beyond the columns defined to be returned by the ResultSet object for a given method can be defined by the JDBC driver vendor and must be accessed by their column label.