Subject: Re: [pgjdbc/pgjdbc] PR #3532: Datetime-related tests improved

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 20 Feb 2025 12:10:26 +0000

(on pgjdbc/src/test/java/org/postgresql/test/DateTimeZoneStamp.java:11)

What is the point of adding this tag/category?

---

From: "seregaizsbera (@seregaizsbera)" <[email-masked]>
Date: Fri, 21 Feb 2025 10:04:37 +0000

So that one can run

```shell
./gradlew test -PincludeTestTags=org.postgresql.test.DateTimeZoneStamp
``` 

At this time it takes about 7 minutes, while the whole testing takes more than 4 hours.

I mentioned it in CONTRIBUTING.md

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Wed, 02 Apr 2025 15:20:14 +0000

Well, the current PR assigns the category to a couple of tests only, and one could just execute the required tests by their respective names.

I am afraid it is not feasible to generate a category for every set of 2-3 test methods.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 02 Apr 2025 15:20:25 +0000

there are other ways to run a single test.