Subject: [pgjdbc/pgjdbc] issue #3560: Regression in 42.7.5: Liquibase fails on second application start with uppercase database name

From: "jeme95 (@jeme95)" <[email-masked]>
Date: Thu, 06 Mar 2025 10:40:10 +0000

**Describe the issue**
After upgrading Spring Boot to **3.4.2**, the PostgreSQL JDBC driver was updated to **42.7.5**.
We are using **Liquibase** for database migrations and have a PostgreSQL database with an **uppercase** name (e.g., `MY_DB`).

Since the upgrade, Liquibase fails on the second application start with the following error:
```vbnet
Caused by: liquibase.exception.DatabaseException: liquibase.exception.DatabaseException: ERROR: relation "dbchangelog" already exists ...

```

**Driver Version:**  42.7.5

**Java Version:** 21

**PostgreSQL Version:** 11.22

**To Reproduce**
Using Liquibase in Spring Boot 3.4.2 with a Postgres database with an uppercase name.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 06 Mar 2025 11:07:16 +0000

see https://github.com/liquibase/liquibase/issues/6666