Subject: Re: [pgjdbc/pgjdbc] PR #3561: remove forcing uppercase and use the function upperCaseFieldLabels instead

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sun, 09 Mar 2025 08:33:10 +0000

What is the intention of the change?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sun, 09 Mar 2025 10:40:03 +0000

Well we had `upperCaseFieldLabels` in there at one point and never used it for all the functions. I just find the code easier to read without \" There should be no change other than that.

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sun, 09 Mar 2025 10:56:54 +0000

Even though we might have a function that forces all the column names go uppercase, it seems wasteful to force the conversion every time as we could just spell the columns so they go uppercase in the first place.

In other words, I'm fine to keep `upperCaseFieldLabels` call. However, it looks we could make the driver more efficient if we keep the quotes so the columns go upper case on their own, and we do not spent time in `upperCaseFieldLabels`

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sun, 09 Mar 2025 10:59:24 +0000

Hard to argue with that. I'm not committed to the PR. It does nothing other than make things nice to read. If we don't use the function then we should get rid of it