Subject: [pgjdbc/pgjdbc] issue #3581: StatementTest.cancelQueryWithBrokenNetwork() fails with JDK24

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 26 Mar 2025 20:16:44 +0000

https://github.com/pgjdbc/pgjdbc/blob/a03f84c6d61333c5a31bcc1e37ee6f78fc90f00c/pgjdbc/src/main/java/org/postgresql/jdbc/PgConnection.java#L1715

throws an exception and the test does not complete

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 27 Mar 2025 07:12:39 +0000

The cause is https://openjdk.org/jeps/486 JEP 486: Permanently Disable the Security Manager, https://github.com/openjdk/jdk/commit/db85090553ab14a84c3ed0a2604dd56c5b6e6982