Subject: [pgjdbc/pgjdbc] issue #3590: Liquibase fails to detect databasechangelog table and crashes with PostgreSQL JDBC driver 42.7.5

From: "805728578 (@805728578)" <[email-masked]>
Date: Tue, 08 Apr 2025 05:34:21 +0000

Please read https://stackoverflow.com/help/minimal-reproducible-example 

**Describe the issue**
A clear and concise description of what the issue is.
Upgrading the PostgreSQL JDBC driver from 42.7.4 to 42.7.5 causes Liquibase to fail during (a second) server startup, as it does not recognize the existing databasechangelog table and attempts to create it again, resulting in an error: relation "databasechangelog" already exists
The error prevents server startup, making the application unusable.

**Driver Version?** 
42.7.5
**Java Version?**
1.8.0_401
**OS Version?**
Windows 10/Ubuntu 22.04
**PostgreSQL Version?**
14.2
**To Reproduce**
Steps to reproduce the behaviour:
PostgreSQL JDBC driver from 42.7.4 to 42.7.5
**Expected behaviour**
A clear and concise description of what you expected to happen.
And what actually happens
42.7.5 is same with 42.7.4 , Case-sensitive
**Logs**
If possible PostgreSQL logs surrounding the occurrence of the issue
Additionally logs from the driver can be obtained adding

Using the following template code make sure the bug can be replicated in the driver alone.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 08 Apr 2025 20:09:44 +0000

Duplicate of #3560