Subject: [pgjdbc/pgjdbc] issue #3591: The Fedora CI seems to fail

From: "praiskup (@praiskup)" <[email-masked]>
Date: Fri, 11 Apr 2025 09:51:38 +0000

For all the PRs, @mkoncek would you mind taking a look and sync with the Fedora downstream?

---

From: "mkoncek (@mkoncek)" <[email-masked]>
Date: Fri, 11 Apr 2025 10:01:34 +0000

Sure.

---

From: "mkoncek (@mkoncek)" <[email-masked]>
Date: Fri, 11 Apr 2025 10:05:06 +0000

`No match for argument: java-17-openjdk-devel`. Right, Java 17 has been dropped and new Java 21 is available in Fedora 42+. This will happen next with Java 25 in roughly half a year.

---

From: "mkoncek (@mkoncek)" <[email-masked]>
Date: Fri, 11 Apr 2025 10:08:39 +0000

Which `.spec` is used as the source for Copr?

---

From: "praiskup (@praiskup)" <[email-masked]>
Date: Tue, 15 Apr 2025 13:37:04 +0000

Sorry for the delay in responses, this: https://github.com/pgjdbc/pgjdbc/blob/master/packaging/rpm/postgresql-jdbc.spec.tpl

---

From: "mkoncek (@mkoncek)" <[email-masked]>
Date: Tue, 15 Apr 2025 13:55:23 +0000

I don't know how your tooling works, whether it has to refer to a file present in this repository. From my view the best solution would be to refer to actual Fedora `.spec` files for each version of Fedora.

In the template file I already see some relicts of ancient times and I am surprised other errors were not shown.

---

From: "praiskup (@praiskup)" <[email-masked]>
Date: Tue, 15 Apr 2025 14:10:56 +0000

> From my view the best solution would be to refer to actual Fedora .spec files for each version of Fedora.

:shrug: this used to work just fine for us (downstream) & upstream back then when I was part of the maintenance team @ Fedora.  But feel free to fix the CI the way you prefer.  Or we can drop it, if you do not need it.

Just note that it is rather long-shot for upstream contributors to fix Fedora spec files just to make the upstream CI green (IOW, if we use one spec file from Fedora centrally - upstream contributors can not fix problems they are causing).

> In the template file I already see some relicts of ancient times and I am surprised other errors were not shown.

Yes, there used to be very verbose comment both sides trying to inform the future maintainers that these files should stay in sync.