Subject: [pgjdbc/pgjdbc] issue #3610: postgresql-42.7.5.jar against a server 17.4 throws an error

From: "bdnced (@bdnced)" <[email-masked]>
Date: Wed, 23 Apr 2025 08:56:03 +0000

**Describe the issue*
Trying to connects with 
- postgres JDBC postgresql-42.7.5.jar 
with libreoffice-base 
--------------------------
Version: 7.4.7.2 / LibreOffice Community
Build ID: 40(Build:2)
CPU threads: 8; OS: Linux 6.1; UI render: default; VCL: gtk3
Locale: de-DE (en_GB.UTF-8); UI: en-GB
Debian package version: 4:7.4.7-1+deb12u7
Calc: threaded
----------------------
against a
- server 17.4 (Ubuntu 17.4-1.pgdg22.04+2))
the pg server is the one running in docker image
dpage/pgadmin4:latest (23.04.2025)
I do get following errors message:
connectivity/source/commontools/dbexceptions.cxx:413
the check of the driver initiated in libreoffice is ok
the error message is appearing when testing the connection in the window setting up connection

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 23 Apr 2025 09:48:46 +0000

I don't have enough information to figure out what went wrong.
What is the name of the database you are connecting to ?