Subject: [pgjdbc/pgjdbc] PR #3651: chore(deps): bump ch.qos.logback:logback-core from 1.2.13 to 1.3.15

From: "dependabot[bot] (bot) (@dependabot[bot])" <noreply+dependabot[bot]@github.com>
Date: Sun, 01 Jun 2025 16:17:15 +0000

Bumps [ch.qos.logback:logback-core](https://github.com/qos-ch/logback) from 1.2.13 to 1.3.15.
<details>
<summary>Commits</summary>
<ul>
<li><a href="https://github.com/qos-ch/logback/commit/81f8c25e2a2fae99f45029c27dc793bdaa8cb079"><code>81f8c25</code></a> remove Stax related code</li>
<li><a href="https://github.com/qos-ch/logback/commit/7cb4834db66b5d68408a79faf602cf3238fd8624"><code>7cb4834</code></a> prepare release 1.3.15</li>
<li><a href="https://github.com/qos-ch/logback/commit/ad9c5e07fd8a25451dc52fde5af3fd92658a9187"><code>ad9c5e0</code></a> StaxEventRecorder was experimental and was never used nor referenced, removing</li>
<li><a href="https://github.com/qos-ch/logback/commit/4cb1053b429858f8e419889e409db7cc2cb81efd"><code>4cb1053</code></a> remove unused package</li>
<li><a href="https://github.com/qos-ch/logback/commit/2863a4974a3649b5b00d4a529ee6ff2063470f35"><code>2863a49</code></a> prevent Server-Side Request Forgery (SSRF) attacks by ignoring external DTD f...</li>
<li><a href="https://github.com/qos-ch/logback/commit/b44b940cc7d4839e06e31a7d60dca174b99c1aa5"><code>b44b940</code></a> remove JaninoEventEvaluator</li>
<li><a href="https://github.com/qos-ch/logback/commit/c17e5883845e5bc4dec49b3fe74f744e0e574a2b"><code>c17e588</code></a> remove JaninoEventEvaluator</li>
<li><a href="https://github.com/qos-ch/logback/commit/c84e7d89c93b7fc177fc2f3708e60e6cf68be30d"><code>c84e7d8</code></a> update license in some old files not part of the ditributed binary</li>
<li><a href="https://github.com/qos-ch/logback/commit/dc2fbb6a72464d9903e676e21171c2e1bc2d9696"><code>dc2fbb6</code></a> start work on 1.3.15-SNAPSHOT</li>
<li><a href="https://github.com/qos-ch/logback/commit/39fc5461e7a8e15ce9ecd9f148f67f701aed88ad"><code>39fc546</code></a> remove unused import</li>
<li>Additional commits viewable in <a href="https://github.com/qos-ch/logback/compare/v_1.2.13...v_1.3.15">compare view</a></li>
</ul>
</details>
<br />

[![Dependabot compatibility score](https://dependabot-badges.githubapp.com/badges/compatibility_score?dependency-name=ch.qos.logback:logback-core&package-manager=gradle&previous-version=1.2.13&new-version=1.3.15)](https://docs.github.com/en/github/managing-security-vulnerabilities/about-dependabot-security-updates#about-compatibility-scores)

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting `@dependabot rebase`.

[//]: # (dependabot-automerge-start)
[//]: # (dependabot-automerge-end)

---

<details>
<summary>Dependabot commands and options</summary>
<br />

You can trigger Dependabot actions by commenting on this PR:
- `@dependabot rebase` will rebase this PR
- `@dependabot recreate` will recreate this PR, overwriting any edits that have been made to it
- `@dependabot merge` will merge this PR after your CI passes on it
- `@dependabot squash and merge` will squash and merge this PR after your CI passes on it
- `@dependabot cancel merge` will cancel a previously requested merge and block automerging
- `@dependabot reopen` will reopen this PR if it is closed
- `@dependabot close` will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
- `@dependabot show <dependency name> ignore conditions` will show all of the ignore conditions of the specified dependency
- `@dependabot ignore this major version` will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
- `@dependabot ignore this minor version` will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
- `@dependabot ignore this dependency` will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
You can disable automated security fix PRs for this repo from the [Security Alerts page](https://github.com/pgjdbc/pgjdbc/network/alerts).

</details>

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Mon, 02 Jun 2025 07:56:23 +0000

I wonder how did this activate. We use renovatebot for managing the dependencies.
`logback` can't be upgraded to 1.3 alone (see https://github.com/pgjdbc/pgjdbc/blob/master/renovate.json#L29)

---

From: "dependabot[bot] (bot) (@dependabot[bot])" <noreply+dependabot[bot]@github.com>
Date: Mon, 02 Jun 2025 15:43:48 +0000

Looks like ch.qos.logback:logback-core is up-to-date now, so this is no longer needed.