Subject: [pgjdbc/pgjdbc] PR #3666: test: extract pgjdbc/testFixtures to testkit project

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sat, 14 Jun 2025 17:16:10 +0000

It enables using shadowed artifacts for `benchmarks` and `osgi-test`

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sun, 15 Jun 2025 19:33:24 +0000

Looks like this is ready. Now both osgi-test and benchmark modules consume the shaded artifact.

At the same time, as we move `TestUtil`-like classes to its own `testkit/src/main` module, we separate "test framework" from "`@test` class" code which is good as well.