Subject: [pgjdbc/pgjdbc] PR #3667: refactor: pass ChannelBinding to ScramAuthenticator instead of passing full Properties

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sun, 15 Jun 2025 15:06:21 +0000

This avoids unexpected dependencies of ScramAuthenticator on the connection properties.

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Sun, 15 Jun 2025 16:22:08 +0000

Is `ChannelBindingRequiredTest` being run in CI? I can't find it in any of the GHA logs: https://github.com/pgjdbc/pgjdbc/actions/runs/15664516400

I would have expected this one with ssl + scram to run it: https://github.com/pgjdbc/pgjdbc/actions/runs/15664516400/job/44126869186

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Sun, 15 Jun 2025 17:31:27 +0000

The log shows only the test with failures, tests with skips, or the ones that are slow.
The rest do not show up in the logs.

You could find all the tests in Gradle Scan report (the link is at the very end of the build log): https://scans.gradle.com/s/t236mif6boifi/tests/overview?class=org.postgresql.test.core.ChannelBindingRequiredTest#:postgresql:test-0-org.postgresql.test.core.channelbindingrequiredtest-31

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Sun, 15 Jun 2025 18:21:13 +0000

Thanks for the explanation!