Subject: [pgjdbc/pgjdbc] PR #3686: chore: migrate publish workflow to Central Portal publishing via com.gradleup.nmcp

From: "vlsi (@vlsi)" <[email-masked]>
Date: Tue, 24 Jun 2025 18:50:00 +0000

The idea is to use GitHub Actions for releasing pgjdbc.

[Central Portal is a requirement](https://central.sonatype.org/news/20250326_ossrh_sunset/) to publish since 30 June, so we need to migrate the workflow.

The suggested flow is as follows:
1. Prepare release notes, commit it to Git.
2. Open the "release" action at 👉 [Actions tab → release.yml](https://github.com/pgjdbc/pgjdbc/actions/workflows/release.yml).
3. Click "run workflow".
4. Set "Release version number" if you want to bump the version before the release. Note: if the current version already exists, then the release workflow would abort.
5. Click "Run workflow"

Open items:
* [ ] Decide which PGP will be used to sign releases. In theory, we can create a new "pgjdbc/pgjdbc signing key"
* [ ] Decide if we want updating the site as a part of the release job
* [ ] Add GitHub App for `actions/create-github-app-token` (see [usage](https://github.com/actions/create-github-app-token?tab=readme-ov-file#usage)) so it could get app tokens for "bump version" commits
* [ ] Test release workflow. I plan testing the workflow in `vlsi/pgjdbc` fork to ensure branch names, and the workflow steps are good for pgjdbc.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 30 Jul 2025 16:12:00 +0000

@vlsi looks like they have turned off oss.sonatype. Can this be merged?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 30 Jul 2025 16:21:12 +0000

Need to update https://github.com/pgjdbc/pgjdbc/blob/b1d3b710b2aabeb6055e25b28392df5e1f1fe64d/CONTRIBUTING.md?plain=1#L175 as well