Subject: [pgjdbc/pgjdbc] PR #3738: fix(deps): update dependency org.junit:junit-bom to v5.13.4

From: "renovate-bot (@renovate-bot)" <[email-masked]>
Date: Mon, 28 Jul 2025 06:00:33 +0000

This PR contains the following updates:

| Package | Change | Age | Confidence |
|---|---|---|---|
| [org.junit:junit-bom](https://junit.org/) ([source](https://redirect.github.com/junit-team/junit-framework)) | `5.13.3` -> `5.13.4` | [![age](https://developer.mend.io/api/mc/badges/age/maven/org.junit:junit-bom/5.13.4?slim=true)](https://docs.renovatebot.com/merge-confidence/) | [![confidence](https://developer.mend.io/api/mc/badges/confidence/maven/org.junit:junit-bom/5.13.3/5.13.4?slim=true)](https://docs.renovatebot.com/merge-confidence/) |

---

### Release Notes

<details>
<summary>junit-team/junit-framework (org.junit:junit-bom)</summary>

### [`v5.13.4`](https://redirect.github.com/junit-team/junit-framework/compare/r5.13.3...r5.13.4)

</details>

---

### Configuration

📅 **Schedule**: Branch creation - "every 3 weeks on Monday" (UTC), Automerge - At any time (no schedule defined).

🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.

♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 **Ignore**: Close this PR and you won't be reminded about this update again.

---

 - [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box

---

This PR was generated by [Mend Renovate](https://mend.io/renovate/). View the [repository job log](https://developer.mend.io/github/pgjdbc/pgjdbc).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0MS40MC4wIiwidXBkYXRlZEluVmVyIjoiNDEuNDAuMCIsInRhcmdldEJyYW5jaCI6Im1hc3RlciIsImxhYmVscyI6WyJkZXBlbmRlbmNpZXMiXX0=-->

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Mon, 28 Jul 2025 10:03:39 +0000

```
FAILURE   1,1sec, org.postgresql.replication.LogicalReplicationStatusTest > keepAliveServerLSNCanBeUsedToAdvanceFlushLSN()
    java.lang.AssertionError: Activity in other database will generate WAL but no XLogData  messages. Received LSN will begin to advance beyond of confirmed flushLSN
    Expected: not <LSN{0/10D4E5F0}>
         but: was <LSN{0/10D4E5F0}>
        at org.hamcrest.MatcherAssert.assertThat(MatcherAssert.java:20)
        at org.postgresql.replication.LogicalReplicationStatusTest.keepAliveServerLSNCanBeUsedToAdvanceFlushLSN(LogicalReplicationStatusTest.java:452)
```

Looks like it is not relate to junit upgrade