Subject: [pgjdbc/pgjdbc] PR #3748: Fix #3747: Incorrect class comparison in PGXmlFactoryFactory validation

From: "eitch (@eitch)" <[email-masked]>
Date: Tue, 29 Jul 2025 14:38:11 +0000

### All Submissions:

* [x] Have you followed the guidelines in our [Contributing](https://github.com/pgjdbc/pgjdbc/blob/master/CONTRIBUTING.md) document?
* [x] Have you checked to ensure there aren't other open [Pull Requests](../../pulls) for the same update/change?

Simple fix for allowing to use a custom PGXmlFactoryFactory

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 29 Jul 2025 18:02:40 +0000

it would be useful to add a test which just tries to load the default like you did in your issue

---

From: "eitch (@eitch)" <[email-masked]>
Date: Wed, 30 Jul 2025 06:22:34 +0000

Yeah, sorry, that was why this was still a draft. I had to find time to figure out the building and everything. It wasn't straightforward to get it to work in IntelliJ. And it doesn't build with Java 24...

Added a test now, looks fine to me.

---

From: "eitch (@eitch)" <[email-masked]>
Date: Thu, 31 Jul 2025 06:05:27 +0000

@davecramer Why did the code style check fail? I can't see any issues with the import statements.

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 31 Jul 2025 08:39:59 +0000

@eitch , the job log lists the deviations: https://github.com/pgjdbc/pgjdbc/actions/runs/16615037950/job/47044488575?pr=3748#step:4:776

---

From: "eitch (@eitch)" <[email-masked]>
Date: Thu, 31 Jul 2025 11:30:48 +0000

I "fixed" the code, but the pipeline fails. Is the PR ok? Is something not correct? Looking at the AppVeyor build log, it seems to just be a broken pipeline due to resources and not due to the code, or did i miss something?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 01 Aug 2025 09:42:51 +0000

appveyor failing is OK, code style not OK

looks like you just have to delete line 17

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Sun, 03 Aug 2025 19:01:46 +0000

Thank you for the fix and the additional test.

---

From: "eitch (@eitch)" <[email-masked]>
Date: Mon, 04 Aug 2025 07:34:46 +0000

Happy to help. When is a new release planned?