Subject: [pgjdbc/pgjdbc] PR #3749: chore(deps): update gradle to v9 - autoclosed

From: "renovate-bot (@renovate-bot)" <[email-masked]>
Date: Fri, 01 Aug 2025 20:03:01 +0000

This PR contains the following updates:

| Package | Update | Change |
|---|---|---|
| [gradle](https://gradle.org) ([source](https://redirect.github.com/gradle/gradle)) | major | `8.14.3` → `9.4.1` |

---

### Release Notes

<details>
<summary>gradle/gradle (gradle)</summary>

### [`v9.4.1`](https://redirect.github.com/gradle/gradle/compare/v9.4.0...v9.4.1)

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v9.4.0...v9.4.1)

### [`v9.4.0`](https://redirect.github.com/gradle/gradle/compare/v9.3.1...v9.4.0)

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v9.3.1...v9.4.0)

### [`v9.3.1`](https://redirect.github.com/gradle/gradle/releases/tag/v9.3.1): 9.3.1

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v9.3.0...v9.3.1)

This is a patch release for 9.3.0. We recommend using 9.3.1 instead of 9.3.0.

The following issues were resolved:

- [Cannot find testcases from Android Screenshot Test plugin since Gradle 9.3.0](https://redirect.github.com/gradle/gradle/issues/36320)
- [Excluding dependencies from included builds doesn't work in Gradle 9.3.0](https://redirect.github.com/gradle/gradle/issues/36331)
- [ExternalDependency and DependencyConstraint cannot be passed to DependencyResolveDetails#useTarget](https://redirect.github.com/gradle/gradle/issues/36359)
- [Gradle 9.3.0 generate JUnit test result files with wrong name](https://redirect.github.com/gradle/gradle/issues/36379)
- [Build cache cannot handle outputs with non-BMP characters in the filename](https://redirect.github.com/gradle/gradle/issues/36387)
- [Emojis in test names should not break build caching](https://redirect.github.com/gradle/gradle/issues/36395)
- [Non utf-8 c code is no longer buildable](https://redirect.github.com/gradle/gradle/issues/36399)
- [Breaking change in 9.3.0 regarding cross-project dependency manipulation](https://redirect.github.com/gradle/gradle/issues/36428)
- [JUnit3 tests cannot be run with Gradle 9.3.0](https://redirect.github.com/gradle/gradle/issues/36451)
- [Test.setScanForTestClasses(false) causes all junit4 tests to be skipped](https://redirect.github.com/gradle/gradle/issues/36508)

[Read the Release Notes](https://docs.gradle.org/9.3.1/release-notes.html)

#### Upgrade instructions

Switch your build to use Gradle 9.3.1 by updating your wrapper:

```
./gradlew wrapper --gradle-version=9.3.1 && ./gradlew wrapper
```

See the Gradle [9.x upgrade guide](https://docs.gradle.org/9.3.1/userguide/upgrading_version_9.html) to learn about deprecations, breaking changes and other considerations when upgrading.

For Java, Groovy, Kotlin and Android compatibility, see the [full compatibility notes](https://docs.gradle.org/9.3.1/userguide/compatibility.html).

#### Reporting problems

If you find a problem with this release, please file a bug on [GitHub Issues](https://redirect.github.com/gradle/gradle/issues) adhering to our issue guidelines.
If you're not sure you're encountering a bug, please use the [forum](https://discuss.gradle.org/c/help-discuss).

We hope you will build happiness with Gradle, and we look forward to your feedback via [Twitter](https://twitter.com/gradle) or on [GitHub](https://redirect.github.com/gradle).

### [`v9.3.0`](https://redirect.github.com/gradle/gradle/compare/v9.2.1...v9.3.0)

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v9.2.1...v9.3.0)

### [`v9.2.1`](https://redirect.github.com/gradle/gradle/releases/tag/v9.2.1): 9.2.1

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v9.2.0...v9.2.1)

The Gradle team is excited to announce Gradle 9.2.1.

Here are the highlights of this release:

- Windows ARM support
- Improved publishing APIs
- Better guidance for dependency verification failures

[Read the Release Notes](https://docs.gradle.org/9.2.1/release-notes.html)

We would like to thank the following community members for their contributions to this release of Gradle:
[Adam](https://redirect.github.com/aSemy),
[Björn Kautler](https://redirect.github.com/Vampire),
[hasunzo](https://redirect.github.com/hasunzo),
[HYEON](https://redirect.github.com/iohyeon),
[Hyunjoon Park](https://redirect.github.com/academey),
[HYUNJUN SON](https://redirect.github.com/guswns1659),
[Jendrik Johannes](https://redirect.github.com/jjohannes),
[Kirill Gavrilov](https://redirect.github.com/gavvvr),
[Madalin Valceleanu](https://redirect.github.com/vmadalin),
[Martin Bonnin](https://redirect.github.com/martinbonnin),
[Matthew Haughton](https://redirect.github.com/3flex),
[Mikhail Polivakha](https://redirect.github.com/mipo256),
[Na Minhyeok](https://redirect.github.com/NaMinhyeok),
[Philip Wedemann](https://redirect.github.com/hfhbd),
[Philipp Schneider](https://redirect.github.com/p-schneider),
[Róbert Papp](https://redirect.github.com/TWiStErRob),
[Simon Marquis](https://redirect.github.com/SimonMarquis),
[TheGoesen](https://redirect.github.com/TheGoesen),
[Vincent Potucek](https://redirect.github.com/Pankraz76),
[Xin Wang](https://redirect.github.com/scaventz).

#### Upgrade instructions

Switch your build to use Gradle 9.2.1 by updating your wrapper:

```
./gradlew wrapper --gradle-version=9.2.1 && ./gradlew wrapper
```

See the Gradle [9.x upgrade guide](https://docs.gradle.org/9.2.1/userguide/upgrading_version_9.html) to learn about deprecations, breaking changes and other considerations when upgrading.

For Java, Groovy, Kotlin and Android compatibility, see the [full compatibility notes](https://docs.gradle.org/9.2.1/userguide/compatibility.html).

#### Reporting problems

If you find a problem with this release, please file a bug on [GitHub Issues](https://redirect.github.com/gradle/gradle/issues) adhering to our issue guidelines.
If you're not sure you're encountering a bug, please use the [forum](https://discuss.gradle.org/c/help-discuss).

We hope you will build happiness with Gradle, and we look forward to your feedback via [Twitter](https://twitter.com/gradle) or on [GitHub](https://redirect.github.com/gradle).

### [`v9.2.0`](https://redirect.github.com/gradle/gradle/compare/v9.1.0...v9.2.0)

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v9.1.0...v9.2.0)

### [`v9.1.0`](https://redirect.github.com/gradle/gradle/releases/tag/v9.1.0): 9.1.0

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v9.0.0...v9.1.0)

The Gradle team is excited to announce Gradle 9.1.0.

Here are the highlights of this release:

- Full Java 25 support
- Native task graph visualization
- Enhanced console output

[Read the Release Notes](https://docs.gradle.org/9.1.0/release-notes.html)

We would like to thank the following community members for their contributions to this release of Gradle:
[Eng Zer Jun](https://redirect.github.com/Juneezee),
[EunHyunsu](https://redirect.github.com/ehs208),
[Gaëtan Muller](https://redirect.github.com/MGaetan89),
[HeeChul Yang](https://redirect.github.com/yangchef1),
[Jendrik Johannes](https://redirect.github.com/jjohannes),
[Johnny Lim](https://redirect.github.com/izeye),
[Junho Lee](https://redirect.github.com/junstory),
[Kirill Gavrilov](https://redirect.github.com/gavvvr),
[Matthew Haughton](https://redirect.github.com/3flex),
[Na Minhyeok](https://redirect.github.com/NaMinhyeok),
[Philip Wedemann](https://redirect.github.com/hfhbd),
[Philipp Schneider](https://redirect.github.com/p-schneider),
[Pradyumna C](https://redirect.github.com/pradyumnac26),
[r-a-sattarov](https://redirect.github.com/r-a-sattarov),
[Ryszard Perkowski](https://redirect.github.com/usultis),
[Sebastian Schuberth](https://redirect.github.com/sschuberth),
[SebastianHeil](https://redirect.github.com/SebastianHeil),
[Staffan Al-Kadhimi](https://redirect.github.com/stafak),
[winfriedgerlach](https://redirect.github.com/winfriedgerlach),
[Xin Wang](https://redirect.github.com/scaventz).

#### Upgrade instructions

Switch your build to use Gradle 9.1.0 by updating your wrapper:

```
./gradlew wrapper --gradle-version=9.1.0 && ./gradlew wrapper
```

See the Gradle [9.x upgrade guide](https://docs.gradle.org/9.1.0/userguide/upgrading_version_9.html) to learn about deprecations, breaking changes and other considerations when upgrading.

For Java, Groovy, Kotlin and Android compatibility, see the [full compatibility notes](https://docs.gradle.org/9.1.0/userguide/compatibility.html).

#### Reporting problems

If you find a problem with this release, please file a bug on [GitHub Issues](https://redirect.github.com/gradle/gradle/issues) adhering to our issue guidelines.
If you're not sure you're encountering a bug, please use the [forum](https://discuss.gradle.org/c/help-discuss).

We hope you will build happiness with Gradle, and we look forward to your feedback via [Twitter](https://twitter.com/gradle) or on [GitHub](https://redirect.github.com/gradle).

### [`v9.0.0`](https://redirect.github.com/gradle/gradle/releases/tag/v9.0.0): 9.0.0

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v8.14.4...v9.0.0)

The Gradle team is excited to announce Gradle 9.0.0.

Here are the highlights of this release:

- Configuration Cache is the recommended execution mode
- Gradle requires JVM 17 or higher to run
- Build scripts use Kotlin 2.2 and Groovy 4.0
- Improved Kotlin DSL script compilation avoidance

[Read the Release Notes](https://docs.gradle.org/9.0.0/release-notes.html)

We would like to thank the following community members for their contributions to this release of Gradle:
[Aaron Matthis](https://redirect.github.com/rapus95),
[Adam E](https://redirect.github.com/adam-enko),
[Adam S](https://redirect.github.com/aSemy),
[Björn Kautler](https://redirect.github.com/Vampire),
[Daniel Lacasse](https://redirect.github.com/lacasseio),
[Eng Zer Jun](https://redirect.github.com/Juneezee),
[EunHyunsu](https://redirect.github.com/ehs208),
[FlorianMichael](https://redirect.github.com/FlorianMichael),
[Francisco Prieto](https://redirect.github.com/priettt),
[Gaëtan Muller](https://redirect.github.com/MGaetan89),
[Jake Wharton](https://redirect.github.com/JakeWharton),
[Kengo TODA](https://redirect.github.com/KengoTODA),
[Kent Kaseda](https://redirect.github.com/kaseken),
[Madalin Valceleanu](https://redirect.github.com/vmadalin),
[Marc Philipp](https://redirect.github.com/marcphilipp),
[Mark S. Lewis](https://redirect.github.com/bestbeforetoday),
[Matthew Haughton](https://redirect.github.com/3flex),
[Mycroft Wong](https://redirect.github.com/MycroftWong),
[Na Minhyeok](https://redirect.github.com/NaMinhyeok),
[Nelson Osacky](https://redirect.github.com/runningcode),
[Olivier "Oli" Dagenais](https://redirect.github.com/olivierdagenais),
[ploober](https://redirect.github.com/ploober),
[Radai Rosenblatt](https://redirect.github.com/radai-rosenblatt),
[Róbert Papp](https://redirect.github.com/TWiStErRob),
[Sebastian Schuberth](https://redirect.github.com/sschuberth),
[Victor Merkulov](https://redirect.github.com/urdak).

#### Upgrade instructions

Switch your build to use Gradle 9.0.0 by updating your wrapper:

```
./gradlew wrapper --gradle-version=9.0.0 && ./gradlew wrapper
```

See the Gradle [9.0.0 upgrade guide](https://docs.gradle.org/9.0.0/userguide/upgrading_major_version_9.html) to learn about deprecations, breaking changes and other considerations when upgrading.

For Java, Groovy, Kotlin and Android compatibility, see the [full compatibility notes](https://docs.gradle.org/9.0.0/userguide/compatibility.html).

#### Reporting problems

If you find a problem with this release, please file a bug on [GitHub Issues](https://redirect.github.com/gradle/gradle/issues) adhering to our issue guidelines.
If you're not sure you're encountering a bug, please use the [forum](https://discuss.gradle.org/c/help-discuss).

We hope you will build happiness with Gradle, and we look forward to your feedback via [Twitter](https://twitter.com/gradle) or on [GitHub](https://redirect.github.com/gradle).

### [`v8.14.4`](https://redirect.github.com/gradle/gradle/compare/v8.14.3...v8.14.4)

[Compare Source](https://redirect.github.com/gradle/gradle/compare/v8.14.3...v8.14.4)

</details>

---

### Configuration

📅 **Schedule**: Branch creation - "every 3 weeks on Monday" (UTC), Automerge - At any time (no schedule defined).

🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.

♻ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 **Ignore**: Close this PR and you won't be reminded about this update again.

---

 - [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box

---

This PR was generated by [Mend Renovate](https://mend.io/renovate/). View the [repository job log](https://developer.mend.io/github/pgjdbc/pgjdbc).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiI0MS40Ni4zIiwidXBkYXRlZEluVmVyIjoiNDMuNjYuNCIsInRhcmdldEJyYW5jaCI6Im1hc3RlciIsImxhYmVscyI6WyJkZXBlbmRlbmNpZXMiXX0=-->

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Tue, 05 Aug 2025 08:08:19 +0000

The update is blocked by https://github.com/lburgazzoli/gradle-karaf-plugin/issues/88