Subject: [pgjdbc/pgjdbc] PR #3758: Fix typo in PGReplicationStream.java

From: "atorik (@atorik)" <[email-masked]>
Date: Mon, 11 Aug 2025 12:44:20 +0000

Hi,

Should "tread safe" be "thread safe"?

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Mon, 11 Aug 2025 12:58:57 +0000

(on pgjdbc/src/main/java/org/postgresql/replication/PGReplicationStream.java:17)

```suggestion
 * Not thread-safe replication stream (though certain methods can be safely called by different
```

WDYT?

---

From: "atorik (@atorik)" <[email-masked]>
Date: Mon, 11 Aug 2025 13:12:53 +0000

Thanks for the quick response!

I searched under pgjdbc/ and “thread safe” seems to be the majority usage, but I’m fine with either.

```
% rg 'thread safe' . | wc -l
      12
% rg 'thread-safe' . | wc -l
       1
```