Subject: [pgjdbc/pgjdbc] PR #3774: fix: Change "PST" timezone in TimestampTest to "Pacific Standard Time"

From: "simon-greatrix (@simon-greatrix)" <[email-masked]>
Date: Tue, 19 Aug 2025 08:54:23 +0000

The timestamp specifier "PST" can be misinterpreted as "Philippine Standard Time" causing the test to fail if Java selects it. Use an unambiguous timezone specifier to ensure desired behaviour.

No breaking changes.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 19 Aug 2025 09:13:36 +0000

> Looks like there was no explicit intention to test specifically for `PST`, so going for a less ambiguous code looks nice

one would think, however if fails all of the tests.

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Tue, 19 Aug 2025 09:13:41 +0000

The tests seem to fail with `Unparseable date: "1950-02-07 15:00:00 Pacific Standard Time"`.
Could you please have a look?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 19 Aug 2025 09:21:23 +0000

> The tests seem to fail with `Unparseable date: "1950-02-07 15:00:00 Pacific Standard Time"`. Could you please have a look?

My guess is that `Pacific Standard Time` did not exist in 1950

Alternatively we could use GMT offsets ?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 19 Aug 2025 09:25:38 +0000

chatgpt https://chatgpt.com/share/68a442c0-9c80-8007-b541-e2f4be77fa36 
GMT offset seems the most robust

---

From: "simon-greatrix (@simon-greatrix)" <[email-masked]>
Date: Tue, 19 Aug 2025 14:59:23 +0000

This is one of those "it works on my machine" issues. My machine fails with the "PST" timestamp and works with the "Pacific Standard Time".

Rather than debugging further - I agree that the spirit of the test is to do some timezone other than UTC. We do not care about how Java parses dates, so replacing PST with "GMT-08:00" should work for everyone.

I have made that change in my fork.