Subject: [pgjdbc/pgjdbc] PR #3776: Fix: BaseDataSource.getProperty mirrors BaseDataSource.setProperty.

From: "simon-greatrix (@simon-greatrix)" <[email-masked]>
Date: Tue, 19 Aug 2025 14:29:10 +0000

The setProperty method of BaseDataSource allows all properties to be set. The getProperty method does not allow the retrieval of: PG_HOST, PG_PORT, PG_DBNAME, USER, and PASSWORD. All properties that can be set should also be readable.

Create unit tests to verify that getting and setting properties works as expected.

Fixes: https://github.com/pgjdbc/pgjdbc/issues/3761

Sorry - I messed up my git repo. I should never have been merging from main. This re-opens https://github.com/pgjdbc/pgjdbc/pull/3762

---

From: "simon-greatrix (@simon-greatrix)" <[email-masked]>
Date: Wed, 27 Aug 2025 07:02:50 +0000

We seem to have lost momentum here. I have a fix with unit tests ready for merge. What are we waiting for?

---

From: "simon-greatrix (@simon-greatrix)" <[email-masked]>
Date: Tue, 09 Sep 2025 07:21:11 +0000

@vlsi  @davecramer  - is there anything I have to do for this merge request? All the checks pass, there are no conflicts - but you guys have gone silent on it?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Tue, 09 Sep 2025 10:09:05 +0000

@simon-greatrix just need to find some time to review it.