Subject: [pgjdbc/pgjdbc] PR #3782: test: add bench for batch insert via unnest with arrays

From: "lantalex (@lantalex)" <[email-masked]>
Date: Fri, 22 Aug 2025 12:37:56 +0000

### All Submissions:

* [x] Have you followed the guidelines in our [Contributing](https://github.com/pgjdbc/pgjdbc/blob/master/CONTRIBUTING.md) document?
* [x] Have you checked to ensure there aren't other open [Pull Requests](../../pulls) for the same update/change?

<!-- You can erase any parts of this template not applicable to your Pull Request. -->

### New Feature Submissions:

1. [x] Does your submission pass tests?
2. [x] Does `./gradlew styleCheck` pass ?
3. [ ] Have you added your new test classes to an existing test suite in alphabetical order?

### Changes to Existing Features:

* [ ] Does this break existing behaviour? If so please explain.
* [ ] Have you added an explanation of what your changes do and why you'd like us to include them?
* [ ] Have you written new tests for your core changes, as applicable?
* [ ] Have you successfully run tests with your changes locally?

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Fri, 22 Aug 2025 13:58:59 +0000

(on benchmarks/src/jmh/java/org/postgresql/benchmark/statement/InsertBatch.java)

```suggestion
    PGConnection pgConnection = connection.unwrap(PGConnection.class);
```