Subject: [pgjdbc/pgjdbc] PR #3783: perf: remove QUERY_ONESHOT flag when calling getMetaData

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Mon, 25 Aug 2025 05:16:11 +0000

### All Submissions:

* [ ] Have you followed the guidelines in our [Contributing](https://github.com/pgjdbc/pgjdbc/blob/master/CONTRIBUTING.md) document?
* [ ] Have you checked to ensure there aren't other open [Pull Requests](../../pulls) for the same update/change?

<!-- You can erase any parts of this template not applicable to your Pull Request. -->

### New Feature Submissions:

1. [ ] Does your submission pass tests?
2. [ ] Does `./gradlew styleCheck` pass ?
3. [ ] Have you added your new test classes to an existing test suite in alphabetical order?

### Changes to Existing Features:

* [ ] Does this break existing behaviour? If so please explain.
* [ ] Have you added an explanation of what your changes do and why you'd like us to include them?
* [ ] Have you written new tests for your core changes, as applicable?
* [ ] Have you successfully run tests with your changes locally?

---

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Mon, 25 Aug 2025 05:28:30 +0000

see #3781

---

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Mon, 25 Aug 2025 08:31:18 +0000

All test cases passed locally. The failure in GitHub Actions seems unrelated to my changes.

---

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Mon, 01 Sep 2025 07:59:25 +0000

cc @davecramer