Subject: [pgjdbc/pgjdbc] PR #3802: fix: Update release plugin config to use .set(...) for props and inject nexus secrets via props

From: "sehrope (@sehrope)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:06:31 +0000

@davecramer Eyeball this one and I guess let's try it out.

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:08:31 +0000

Could you please clarify the reason for the change?

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:09:03 +0000

(on build-logic/root-build/src/main/kotlin/build-logic.root-build.gradle.kts:17)

Just wondering, why replacing `=` with `.set`?

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:09:54 +0000

Hopefully to fix releasing to actually work: https://github.com/pgjdbc/pgjdbc/actions/runs/17837108128

Unless you think it's something else that's causing it. The error in that run is complaining that the username is not populated.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:10:06 +0000

well as you can see from the failed release, whatever we have now doesn't work

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:21:09 +0000

@vlsi Are you going to fix the release workflow or have an alternative idea as to what's wrong? If so, let us know, otherwise going to proceed with this in a few minutes to try it out.

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:49:51 +0000

Exactly the same code works for me in a different project: https://github.com/Netcracker/qubership-profiler-agent/blob/c71efd9d52f6d61ddc608d1a46ea9437fa04e3b8/build-logic/root-build/src/main/kotlin/build-logic.root-build.gradle.kts#L10

I don't see reasons to go for properties and so on. So I wonder why do you suggest the changes

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 18 Sep 2025 19:56:33 +0000

Note: you can debug release workflows in your fork repository, so you don't need to merge fixes just to test them.