Subject: Re: [pgjdbc/pgjdbc] PR #3819: create action to deploy docs to https://pgjdbc.github.io/

From: "vlsi (@vlsi)" <[email-masked]>
Date: Fri, 26 Sep 2025 15:37:50 +0000

(on .github/workflows/docs.yml)

We probably want running it with the latest tag only. For instance, if we release a fix for an older version, we don't updating the site from the old sources.

One of the options could be going for a manual execution (see https://github.com/pgjdbc/pgjdbc/blob/c1c469e8fd9d37f0bcd71966753d72fb584c1f3f/.github/workflows/release.yml#L4)

Another option could be skipping the workflow for "non-mainline" tags somehow.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 26 Sep 2025 15:48:06 +0000

good point.

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Fri, 26 Sep 2025 18:40:35 +0000

(on .github/workflows/docs.yml:5)

Do we publish releases for back patched versions? If so, I think this would trigger a build when that happens and the source checked out would default to the ref that generated the release event.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 26 Sep 2025 19:01:51 +0000

I guess we can just leave it as manual ?

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Mon, 29 Sep 2025 19:05:34 +0000

I believe "release published" is not the right trigger.
Releasing the fix for an older release would update the site with an old contents. It is not something we want.

We should rather add a branch like `website` which we could update during the release if releasing from the master branch.