Subject: [pgjdbc/pgjdbc] PR #3838: fix: Issue #3784 pgjdbc can't decode numeric arrays containing special numbers like NaN

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Mon, 13 Oct 2025 06:23:17 +0000

fix #3784

---

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Thu, 23 Oct 2025 05:22:34 +0000

cc @davecramer

---

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Fri, 31 Oct 2025 08:37:20 +0000

ping @davecramer

---

From: "bokken (@bokken)" <[email-masked]>
Date: Sat, 01 Nov 2025 01:55:25 +0000

(on pgjdbc/src/main/java/org/postgresql/jdbc/ArrayDecoding.java:316)

This change seems non-passive. Am I missing something?

---

From: "bokken (@bokken)" <[email-masked]>
Date: Sat, 01 Nov 2025 01:57:38 +0000

(on pgjdbc/src/test/java/org/postgresql/test/jdbc2/ArrayTest.java:118)

This does seem non passive.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sat, 01 Nov 2025 09:51:26 +0000

Well there's no other way to represent NaN. It does pass all of our tests, 
Do you want to revert this ?

---

From: "bokken (@bokken)" <[email-masked]>
Date: Sat, 01 Nov 2025 13:58:45 +0000

It passes the tests after changing them.
The existing (unchanged) tests failed with a class cast exception.
I think it does need to be reverted.

We have discussed the lack of support for these special values in the past. It has been longstanding.

There are not great options.
1 would be a config for how to support/map numeric arrays.
2 would be to dynamically adjust the array type based on presence of these special values

---

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Mon, 08 Dec 2025 06:18:57 +0000

@bokken Hello, I have resubmitted the PR according to your instructions. Could you please help me review it #3888

---

From: "ShenFeng312 (@ShenFeng312)" <[email-masked]>
Date: Mon, 08 Dec 2025 06:19:30 +0000