Subject: [pgjdbc/pgjdbc] issue #3846: Property `quoteReturningIdentifiers` default value document not match code

From: "sodekim (@sodekim)" <[email-masked]>
Date: Fri, 24 Oct 2025 08:35:36 +0000

Please read https://stackoverflow.com/help/minimal-reproducible-example 

**Describe the issue**

in document default value is `false`

<img width="1995" height="150" alt="Image" src="https://github.com/user-attachments/assets/ec42ce04-ec55-44f5-8e9f-3da66babcd2a" />

in code  `org.postgresql.PGProperty#QUOTE_RETURNING_IDENTIFIERS` default value is `true` 

<img width="1245" height="369" alt="Image" src="https://github.com/user-attachments/assets/05a09aa9-7d2a-45ae-bd7d-012b728759a8" />

**Driver Version?** 
42.3.8

**Java Version?**
1.8

**OS Version?**
windows 11

**PostgreSQL Version?**
17.6

**To Reproduce**
No

**Expected behaviour**
keep document and code have same default value

**Logs**
No

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 24 Oct 2025 11:31:42 +0000

can you provide us with a PR ?

---

From: "sodekim (@sodekim)" <[email-masked]>
Date: Fri, 24 Oct 2025 15:27:16 +0000

> can you provide us with a PR ?

see #3847