Subject: [pgjdbc/pgjdbc] PR #3849: Small simplication of locking patterns in QueryExecutorBase

From: "Sanne (@Sanne)" <[email-masked]>
Date: Thu, 30 Oct 2025 15:56:06 +0000

Shouldn't affect any behavioural aspect, other than being slightly lighter on resources.
As suggested on:
 - https://github.com/pgjdbc/pgjdbc/issues/3835#issuecomment-3460719378

This would probably fix the particular issue reported as #3835 as a side-effect.

---

From: "Sanne (@Sanne)" <[email-masked]>
Date: Thu, 30 Oct 2025 16:50:30 +0000

thanks @vlsi !