Subject: [pgjdbc/pgjdbc] PR #3890: WIP add ability to create holdable cursors at the protocol level

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sun, 07 Dec 2025 14:36:45 +0000

relies on patch to postgres attached 0001-wip-holdable-portals.patch

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 05 Mar 2026 11:50:58 +0000

I have submitted a change to postgres, not sure when or if this will get merged in https://commitfest.postgresql.org/patch/6292/

---

From: "reinhapa (@reinhapa)" <[email-masked]>
Date: Mon, 09 Mar 2026 14:11:59 +0000

@davecramer your enhancement would fix a problem with our software, that uses the hold-over-commit cursors. Nice work as I can see!

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 09 Mar 2026 15:36:05 +0000

This requires a patch to the server. Please comment on https://www.postgresql.org/message-id/CADK3HHKe1PA1U6aB5-7tWBQ0yZGgNvY7H=[email-masked] and tell them how important it is to you.