Subject: Re: [pgjdbc/pgjdbc] PR #3908: Added changelogs for version 42.7.9

From: "sehrope (@sehrope)" <[email-masked]>
Date: Wed, 14 Jan 2026 19:58:17 +0000

Does this include the `Class.forName(...)` change to disable initialization that was just merged? I don't see 6a20574f4c896b3f02d7f36d21ab1f3da15c3936 referenced anywhere in the updated changelogs.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Wed, 14 Jan 2026 19:59:42 +0000

> Does this include the `Class.forName(...)` change to disable initialization that was just merged? I don't see [6a20574](https://github.com/pgjdbc/pgjdbc/commit/6a20574f4c896b3f02d7f36d21ab1f3da15c3936) referenced anywhere in the updated changelogs.

It does, but it isn't in there because it was pushed in directly I can make a note of it as well

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Thu, 15 Jan 2026 07:17:22 +0000

(on docs/content/changelogs/2026-01-14-42.7.9-release.md)

```suggestion
* fix: avoid memory leaks in Java <= 21 caused by Thread.inheritedAccessControlContext [PR #3886](https://github.com/pgjdbc/pgjdbc/pull/3886)
```

---

From: "lobaorn-bitso (@lobaorn-bitso)" <[email-masked]>
Date: Thu, 15 Jan 2026 15:54:32 +0000

(on docs/layouts/partials/home/info.html)

Hey @davecramer this is correct? 2026-01-42 seems wrong.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 15 Jan 2026 16:29:29 +0000

Yeah, good call, thanks!

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 15 Jan 2026 16:42:41 +0000

fixed