Subject: Re: [pgjdbc/pgjdbc] PR #3909: lastEditYear to 2026 and bump version

From: "lobaorn-bitso (@lobaorn-bitso)" <[email-masked]>
Date: Thu, 15 Jan 2026 20:46:57 +0000

Hey @davecramer sorry to ask, but the release page shows a release but the version is a -SNAPSHOT, is that correct / expected?

https://github.com/pgjdbc/pgjdbc/releases

Because from my pov, should be either both 42.7.9 or 42.7.9-SNAPSHOT or else it gets confusing...

---

From: "lobaorn-bitso (@lobaorn-bitso)" <[email-masked]>
Date: Thu, 15 Jan 2026 20:50:19 +0000

I mean the asset: https://github.com/pgjdbc/pgjdbc/releases/download/REL42.7.9/postgresql-42.7.9-SNAPSHOT.jar

<img width="971" height="406" alt="Screenshot 2026-01-15 at 17 49 28" src="https://github.com/user-attachments/assets/470442c7-ba33-4892-be3a-d091db0bc824" />

---

From: "lobaorn-bitso (@lobaorn-bitso)" <[email-masked]>
Date: Thu, 15 Jan 2026 20:51:31 +0000

Because the previous one was not like that, and we can not see the release 42.7.9 in maven: https://mvnrepository.com/artifact/org.postgresql/postgresql

<img width="971" height="406" alt="Screenshot 2026-01-15 at 17 50 49" src="https://github.com/user-attachments/assets/9e424331-57f2-49c6-9515-5025fc72c2dc" />

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Thu, 15 Jan 2026 20:56:26 +0000

Well you are correct about the assets being wrong, but the correct jar was uploaded to sonatype
https://repo1.maven.org/maven2/org/postgresql/postgresql/42.7.9/

---

From: "lobaorn-bitso (@lobaorn-bitso)" <[email-masked]>
Date: Fri, 16 Jan 2026 11:06:15 +0000

Hey @davecramer sorry to bother again, but in this case, should the site have been updated as well? It does not show there the 42.7.9, nor in the changelogs: https://jdbc.postgresql.org/ https://jdbc.postgresql.org/changelogs/

And I usually check the release/versions in this site, not sure what the difference is in regard to sonatype, but it was still not reflected there: https://mvnrepository.com/artifact/org.postgresql/postgresql which usually was quite fast, but now its so many hours that seems to be strange...

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 16 Jan 2026 11:12:09 +0000

> Hey @davecramer sorry to bother again, but in this case, should the site have been updated as well? It does not show there the 42.7.9, nor in the changelogs: https://jdbc.postgresql.org/ https://jd…
Yes, that should have updated automatically. Thanks for the heads up.
> And I usually check the release/versions in this site, not sure what the difference is in regard to sonatype, but it was still not reflected there: https://mvnrepository.com/artifact/org.postgresql…
As for this, I have no idea. This is out of our control, but if I follow the links there for maven I end up here. https://repo1.maven.org/maven2/org/postgresql/postgresql/42.7.9/

---

From: "lobaorn-bitso (@lobaorn-bitso)" <[email-masked]>
Date: Fri, 16 Jan 2026 12:38:28 +0000

Not sure what happened but it does not have a comment from you, only the quote from my original message...

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 16 Jan 2026 13:35:07 +0000

OK, fixed, thanks for keeping us honest.