Subject: [pgjdbc/pgjdbc] PR #3937: Create DisabledIfServerGreater annotation

From: "davecramer (@davecramer)" <[email-masked]>
Date: Mon, 09 Feb 2026 20:18:24 +0000

for disabling tests for newer server versions

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Sat, 14 Feb 2026 14:51:23 +0000

(on pgjdbc/src/test/java/org/postgresql/test/jdbc2/PreparedStatementTest.java:475)

Previously this test would only run if the version was >=18.

With this change it only runs if it's <=18.

Is that intentional? Alternatively, am I misunderstanding how these methods work?

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Sat, 14 Feb 2026 16:28:46 +0000

Correct, the change was in 19