Subject: [pgjdbc/pgjdbc] PR #3945: docs: add SCRAM authentication test setup section to TESTING.md

From: "emmaeng700 (@emmaeng700)" <[email-masked]>
Date: Mon, 23 Feb 2026 13:11:03 +0000

Fixes #2083

Added a new section 9 to TESTING.md documenting the required setup
for SCRAM authentication tests (ScramTest).

Previously there was no documentation explaining that:
- pg_hba.conf must be configured with scram-sha-256 for the testscram user
- The testscram user password must be set after SCRAM is enabled

Added instructions for both Docker and manual PostgreSQL setup.

---

From: "vlsi (@vlsi)" <[email-masked]>
Date: Mon, 23 Feb 2026 13:30:25 +0000

(on TESTING.md)

What do you mean by "silently pass"? The test would skip rather than pass.

---

From: "emmaeng700 (@emmaeng700)" <[email-masked]>
Date: Mon, 23 Feb 2026 13:33:27 +0000

(on TESTING.md)

Good catch, you're right — I'll update that to "skip" to be more accurate. 
Will push a fix shortly.