Subject: [pgjdbc/pgjdbc] PR #3959: Make sure we unlock the lock in QueryExecutorImpl if an error occurs

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 13 Mar 2026 15:26:00 +0000

Fixes Issue #3957 

We were not clearing the lock if an exception occurred.

---

From: "davecramer (@davecramer)" <[email-masked]>
Date: Fri, 13 Mar 2026 18:12:44 +0000

closing in favor of #3960