Subject: [pgjdbc/pgjdbc] PR #4040: Restrict test with scram_iterations to v16+ and release notes

From: "sehrope (@sehrope)" <[email-masked]>
Date: Mon, 27 Apr 2026 17:05:04 +0000

One of the new scram max iterations tests uses the `scram_iterations` GUC but that's only available in v16+. So we restrict that one test accordingly via `@EnabledForServerVersionRange("16")`.

Also updates the CHANGELOG with the fix itself.

---

From: "sehrope (@sehrope)" <[email-masked]>
Date: Mon, 27 Apr 2026 17:32:33 +0000

The one failure does not seem like it's related to this PR at all:

```
org.postgresql.test.jdbc2.StatementTest > fastCloses() failure marker
FAILURE  44,4sec, org.postgresql.test.jdbc2.StatementTest > fastCloses()
    java.util.concurrent.TimeoutException: fastCloses() timed out after 40 seconds
        at java.base/java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:290)
        at java.base/java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(ForkJoinPool.java:1020)
        at java.base/java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:1656)
        at java.base/java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1594)
        at java.base/java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:183)

          2,2sec, org.postgresql.test.jdbc2.StatementTest > cancelQueryWithBrokenNetwork()
          2,2sec, org.postgresql.test.jdbc2.StatementTest > sideStatementFinalizers()
          4,1sec, org.postgresql.test.jdbc2.StatementTest > setQueryTimeoutWithSleep()
          2,1sec, org.postgresql.test.jdbc2.StatementTest > setQueryTimeoutWithoutExecute()
          3,3sec, org.postgresql.test.jdbc2.StatementTest > setQueryTimeoutOnPrepared()
FAILURE  74,8sec,   43 completed,   1 failed,   0 skipped, org.postgresql.test.jdbc2.StatementTest
```

It runs fine locally for me and the rest of the matrix is fine too. More than likely it's related to the ongoing GitHub service interruption.