agora inbox for pgpool-committers@postgresql.orghelp / color / mirror / Atom feed
pgpool: Rename libpcp to libpgpoolpcp to avoid conflict with RHEL PCP l 2+ messages / 1 participants [nested] [flat]
* pgpool: Rename libpcp to libpgpoolpcp to avoid conflict with RHEL PCP l @ 2026-01-29 14:14 Bo Peng <pengbo@sraoss.co.jp> 0 siblings, 0 replies; 2+ messages in thread From: Bo Peng @ 2026-01-29 14:14 UTC (permalink / raw) To: pgpool-committers@lists.postgresql.org Rename libpcp to libpgpoolpcp to avoid conflict with RHEL PCP library. The libpcp.so library provided by Pgpool-II conflicts with libpcp.so shipped by RHEL. To avoid this conflict, the Pgpool-II libpcp library has been renamed to libpgpoolpcp. Branch ------ V4_7_STABLE Details ------- https://git.postgresql.org/gitweb?p=pgpool2.git;a=commitdiff;h=940f9e848d7b7b1972e47b27cd5672951ccfa... Modified Files -------------- src/libs/pcp/Makefile.am | 10 +++++----- src/pgpool.spec | 6 +++--- src/sql/pgpool_adm/Makefile | 2 +- src/tools/pcp/Makefile.am | 30 +++++++++++++++--------------- 4 files changed, 24 insertions(+), 24 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
* pgpool: Rename libpcp to libpgpoolpcp to avoid conflict with RHEL PCP l @ 2026-01-29 14:15 Bo Peng <pengbo@sraoss.co.jp> 0 siblings, 0 replies; 2+ messages in thread From: Bo Peng @ 2026-01-29 14:15 UTC (permalink / raw) To: pgpool-committers@lists.postgresql.org Rename libpcp to libpgpoolpcp to avoid conflict with RHEL PCP library. The libpcp.so library provided by Pgpool-II conflicts with libpcp.so shipped by RHEL. To avoid this conflict, the Pgpool-II libpcp library has been renamed to libpgpoolpcp. Branch ------ master Details ------- https://git.postgresql.org/gitweb?p=pgpool2.git;a=commitdiff;h=3a913371009be293dd496d6e630b9ea26eac4... Modified Files -------------- src/libs/pcp/Makefile.am | 10 +++++----- src/pgpool.spec | 6 +++--- src/sql/pgpool_adm/Makefile | 2 +- src/tools/pcp/Makefile.am | 30 +++++++++++++++--------------- 4 files changed, 24 insertions(+), 24 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
end of thread, other threads:[~2026-01-29 14:15 UTC | newest] Thread overview: 2+ messages (download: mbox mbox.gz follow: Atom feed) -- links below jump to the message on this page -- 2026-01-29 14:14 pgpool: Rename libpcp to libpgpoolpcp to avoid conflict with RHEL PCP l Bo Peng <pengbo@sraoss.co.jp> 2026-01-29 14:15 pgpool: Rename libpcp to libpgpoolpcp to avoid conflict with RHEL PCP l Bo Peng <pengbo@sraoss.co.jp>
This inbox is served by agora; see mirroring instructions for how to clone and mirror all data and code used for this inbox