Subject: Support for RHEL/Rocky Linux 10

From: Bo Peng <[email-masked]>
Date: Mon, 6 Oct 2025 01:47:45 +0000

We would like to inform Pgpool-II users about the support plan for RHEL/Rocky Linux 10.

Support for RHEL/Rocky Linux 10 will be introduced in the next major release (Pgpool-II 4.7), which is scheduled for the end of this year.

For Pgpool-II 4.6 and earlier versions, RPM packages for RHEL/Rocky Linux 10 are planned to be released with the minor release scheduled for February 19, 2026.

Best regards,

---
Bo Peng <[email-masked]>
SRA OSS K.K.
TEL: 03-5979-2701 FAX: 03-5979-2702
Mobile: 080-7752-0749
URL: https://www.sraoss.co.jp/

---

From: zam bak <[email-masked]>
Date: Mon, 6 Oct 2025 08:41:28 -0400

Hello Bo

> For Pgpool-II 4.6 and earlier versions, RPM packages for RHEL/Rocky Linux 10 are planned to be released with the minor release scheduled for February 19, 2026.

Is there any chance of reconsidering this timeline to be sooner?

I am specifically asking about re-releasing the current version
PgPool-II v4.6 but built for RHEL/RL v10 and compiled against
PostgreSQL v18 !
Waiting until February 19, 2026 puts a burden on customer upgrades
(those wanting to use PG 18)...
PostgreSQL 18 was officially released on September 25, 2025 and
releasing the compatible PgPool version on  February 19, 2026 would
mean having to wait almost 6 months !

For reference, Red Hat Enterprise Linux (RHEL) v10 was released on May
20th, 2025 <1>, and its derivatives roughly a month later (Rocky Linux
v10 was released on June 11th, 2025)  <2>

Thanks
Z

<1> https://access.redhat.com/articles/3078
<2> https://rockylinux.org/news/rocky-linux-10-0-ga-release

---

From: Bo Peng <[email-masked]>
Date: Fri, 10 Oct 2025 06:57:39 +0000

Hi,

> Is there any chance of reconsidering this timeline to be sooner?

Thank you for your request.
After discussion within the development team, we plan to include support for Rocky Linux 10 and
PostgreSQL 18 in the upcoming minor release scheduled on November 21.

Thank you for your understanding and support.

Best regards,

________________________________________
差出人: zam bak <[email-masked]>
送信: 2025 年 10 月 6 日 (月曜日) 21:41
宛先: Bo Peng <[email-masked]>
Cc: [email-masked] <[email-masked]>
件名: Re: Support for RHEL/Rocky Linux 10

Hello Bo

Thanks
Z