Subject: Fix comment for read_kind_from_backend

From: Tatsuo Ishii <[email-masked]>
Date: Fri, 29 May 2026 08:20:51 +0900 (JST)

I found a minor mistake in read_kind_from_backend comment.
I will push after June minor releases.

Regards,
--
Tatsuo Ishii
SRA OSS K.K.
English: http://www.sraoss.co.jp/index_en/
Japanese:http://www.sraoss.co.jp
diff --git a/src/protocol/pool_process_query.c b/src/protocol/pool_process_query.c
index dacaa9d5a..38ad89185 100644
--- a/src/protocol/pool_process_query.c
+++ b/src/protocol/pool_process_query.c
@@ -3406,9 +3406,9 @@ read_kind_from_backend(POOL_CONNECTION *frontend, POOL_CONNECTION_POOL *backend,
 		read_kind_from_one_backend(frontend, backend, (char *) &kind, MAIN_NODE_ID);
 
 		/*
-		 * If we received a notification message in native replication mode,
-		 * other backends will not receive the message. So we should skip
-		 * other nodes otherwise we will hang in pool_read.
+		 * If we received a notification message in streaming replication
+		 * mode, other backends will not receive the message. So we should
+		 * skip other nodes. Otherwise we will hang in pool_read.
 		 */
 		if (kind == 'A')
 		{

---

From: Tatsuo Ishii <[email-masked]>
Date: Fri, 05 Jun 2026 13:44:59 +0900 (JST)

> I will push after June minor releases.

Fix pushed.
https://git.postgresql.org/gitweb/?p=pgpool2.git;a=commit;h=466e65d77bee1c7650e376f884396fe4e7fb6092

Regards,