Subject: Use PGPOOL 4.6.2, but backend PG is version 14

From: 刘进央 <[email-masked]>
Date: Mon, 22 Dec 2025 16:41:46 +0800 (GMT+08:00)

Hi,

 PGPOOL hackers,

 Now I want to use PGPOOL 4.6.2, but my backend is PG14.

 At present, 4.6.2 supports PG 17 parser, I want to know if there is any compatibility issue？ For example, is there any syntax supported by PG14 but not supported by PG17?

 could you please help clarify this?

 Thanks a lot!

---

From: Koshino Taiki <[email-masked]>
Date: Tue, 23 Dec 2025 08:23:36 +0000

Hi,

From the Pgpool-II point of view, using Pgpool-II 4.6.2 with a PostgreSQL 14 backend should generally be fine.

However, Pgpool-II 4.6.2 uses the PostgreSQL 17 parser internally. If there are any SQL syntaxes that are accepted in PostgreSQL 14 but are no longer supported or have different behavior in PostgreSQL 17, Pgpool-II may fail to parse such SQL statements correctly.

For details about SQL syntax compatibility between PostgreSQL 14 and PostgreSQL 17,
we recommend that you consult the PostgreSQL community.

Best regards,

Taiki Koshino<[email-masked]>
SRA OSS K.K.
TEL: 03-5979-2701 FAX: 03-5979-2702
URL: https://www.sraoss.co.jp/

________________________________
差出人: 刘进央 <[email-masked]>
送信: 2025 年 12 月 22 日 (月曜日) 17:41
宛先: [email-masked] <[email-masked]>
件名: Use PGPOOL 4.6.2, but backend PG is version 14

Hi,

 PGPOOL hackers,

 Thanks a lot!